re = /((((о|е|ё)(в|ц)а?)|((ы|и)на?))|(о|а(й|к|у|ч)?)|(к((о|и)й|ая))|(и(ч|ц))|((ы|и)(х|й)|ая)|((у|ю|о)(к|н|б))|(штейн|манн?|сон))\b/m
str = 'Смирнов/Cмиров
Николаев/Николаева
Никитин/Никитина
Киселёв/Киселёва
Пятницын/Пятницына
Крыленко
Хованский/Хованская
Калита
Шемяка
Донской/Донская
Теплых
Усович
Царук
Нагорный/Нагорная
Деньнуб
Заренок
Шевчук
Драгун
Харинтон
Горбатых
Фидорец
Слободенюк
Кравчук
Голицын
Лифшиц
Либерман
Капица
Айнштейн
Лазерсон
Байдачный/Байдачная
Зварыкин/Зварыкина
Коллонтай
Cобчак
Ландау
Василец
Кучерявый
Бородач
Грицюк
Радаев
Белаец
Деев
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end