#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:^[A-Za-z].*\R\K|(?!^)\G)(?=(?:[A-Za-z].*\R)*(?:Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)\d{4}\b)"
Local $sString = "Xbo" & @CRLF & _
"Play" & @CRLF & _
"Sep2018" & @CRLF & _
"/////////////////////////" & @CRLF & _
"reregg" & @CRLF & _
"95959" & @CRLF & _
"1151" & @CRLF & _
"Zbo" & @CRLF & _
"Tlay" & @CRLF & _
"Jul2018"
Local $sSubst = "0\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)