// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)\b\d+\.\d+
.+?(?=\d+\.\d+|$)").unwrap();
let string = "1.1 This is the 2,1 first 1.2 This is the 2,2 second 1.3 This is the 2,3 third
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}