use strict;
my $str = 'ffffasfsaf242343242
2vv4fj222
555553jjjjjj
fdsfafadsfdf
234234324232
4444fasdfasf
3j3j3j3j3j3
11111jjjjjnnn
ffffa888883j3j3j3j3j33j3j3j3j3j3411jjjjjnnn';
my $regex = qr/([a-z]{5,})(\d{4,})|(\d{4,})([a-z]{5,})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}