#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(^|.+)_-"
Local $sString = "The.Last.of.Us.S01E05.MULTi.1080p.HMAX.WEB-DL.DDP5.1.Atmos.H.264-PSiG"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")