re = /(^|.+)_-/i
str = 'The.Last.of.Us.S01E05.MULTi.1080p.HMAX.WEB-DL.DDP5.1.Atmos.H.264-PSiG'
# Print the match result
str.match(re) do |match|
puts match.to_s
end