using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"A\d\s(.*\.)";
string input = @"
A2 A1 B.
A1 B.
A3 A1 B.";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}