package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)A\d\s(.*\.)`)
var str = `
A2 A1 B.
A1 B.
A3 A1 B.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}