$re = '/A\d\s(.*\.)/im';
$str = '
A2 A1 B.
A1 B.
A3 A1 B.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);