#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https?:\/\/\S+\.[^()]+(?:\([^)]*\))*"
Local $sString = "https://testing.go.id/kantal-(1)(2)" & @CRLF & _
"(e.g. https://testing.go.id/beginilah-jika-kita-suka-haha)" & @CRLF & _
"" & @CRLF & _
"https://green.kumparan.com/kantal-(1)(2)" & @CRLF & _
"(e.g. https://green.kumparan.com/kantal-(1)(2))" & @CRLF & _
"(e.g. https://green.kumparan.com/beginilah-jika-kita-suka-haha)" & @CRLF & _
"" & @CRLF & _
"https://green.kumparan.com/kantal-(1)(2)" & @CRLF & _
"" & @CRLF & _
"(e.g. https://green.kumparan.com/beginilah-jika-kita-suka-haha.jpg?haha=hoho&hehe$)" & @CRLF & _
"" & @CRLF & _
"https://blue.kumparan.com/kantal-(1)(2)" & @CRLF & _
"(e.g. https://blue.kumparan.com/kantal-(1)(2))" & @CRLF & _
"(e.g. https://blue.kumparan.com/beginilah-jika-kita-suka-haha)" & @CRLF & _
"" & @CRLF & _
"https://blue.kumparan.com/kantal-(1)(2)" & @CRLF & _
"" & @CRLF & _
"(e.g. https://blue.kumparan.com/beginilah-jika-kita-suka-haha)" & @CRLF & _
"" & @CRLF & _
"https://blue.kumparan.com/image/upload/f_jpg,fl_progressive,fl_lossy,c_fill,g_face,q_auto:best,w_480,ar_5:7/v1554524445/r6dxtztvmtw9by9oaibe.jpg" & @CRLF & _
"" & @CRLF & _
"url(https://blue.kumparan.com/uikit-assets/assets/logos/404-653d82fd9ae91d1d6cf474e4fd929e47.png)" & @CRLF & _
"" & @CRLF & _
"https://green.kumparan.com/image/upload/fl_progressive,fl_lossy,c_fill,q_auto:best,w_480,ar_5:7/v1553692790/jpgffb7pcs8yo7v0rs2y.jpg" & @CRLF & _
"url(https://green.kumparan.com/image/upload/fl_progressive,fl_lossy,c_fill,q_auto:best,w_640/v1554524445/r6dxtztvmtw9by9oaibe.jpg)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")