const regex = new RegExp('="([^"]*)%7B%7B(%20)?(.+?)(%20)?%7D%7D([^"]*?)"', 'gmi')
const str = `<a href="mailto:%7B%7B%20<Test>%20%7D%7D?subject=x"
`;
const subst = `="\1{{\2}}\3"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);