using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^{\}]+(?=})";
string input = @"<div id=""text-module-container-eb7272147"" class=""text-module-container""><style>#123-module-container-eb7272147 p{text-color:#211E22;bgcolor:test;} #text-module-container-eb7272147 p{color:#211E1E;} #text-module-container-eb7272147 p{color:#123444;} </style><div style=""background-color: rgb(168, 27, 219); color: rgb(33, 30, 30);""><span style=""color:#3498db;"">Click the edit button to replace this conte</span>nt with your own.</div></div>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}