use strict;
my $str = 'parent[0].child
parent.child
parent.child1.list[0].child2
parent[500].child
parent0.child
par50ent.child
parent[0].child1[20].child[0]
And some invalid examples are
parent..child
parent[].child
parent[1a].child
parent[a].child
.parent
parent.
I don\'t know much about regular expressions, so what I came up with is this following line:';
my $regex = qr/^\b(?>\.?\w+(?:\[\d+\])?)+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}