re = /^[a-zA-Z]*0*|[a-zA-Z]+/m
str = 'U01234BC
001111
1Z4R00567U
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result