#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\r?\n[^\S\r\n]*[([].+[)\]](?:\r?\n(?![^\S\r\n]*[\[\]()]).*)*\r?\n[^\S\r\n]*[\{(].+\n"
Local $sString = "speaker1: hello" & @CRLF & _
"" & @CRLF & _
" speaker2: hello (clears throat), let me show you something Ted Cruz said last week" & @CRLF & _
"" & @CRLF & _
" (begin audio clip)" & @CRLF & _
"" & @CRLF & _
" Ted Cruz (R-TX): My dad did not shoot JFK, why do people keep saying that?" & @CRLF & _
"" & @CRLF & _
" (end audio clip)" & @CRLF & _
"" & @CRLF & _
" speaker1: now isn't that interesting"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)