re = /\r?\n[^\S\r\n]*[([].+[)\]](?:\r?\n(?![^\S\r\n]*[\[\]()]).*)*\r?\n[^\S\r\n]*[\{(].+\n/m
str = 'speaker1: hello
speaker2: hello (clears throat), let me show you something Ted Cruz said last week
(begin audio clip)
Ted Cruz (R-TX): My dad did not shoot JFK, why do people keep saying that?
(end audio clip)
speaker1: now isn\'t that interesting'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result