package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\]<>%!~"§$#%*&/|\\+()=?{}[$]|[0-9]`)
var str = `!
"
§
$
%
&
/
(
)
=
?
{
}
[
]
\
#
*
+
~
<
>
|
dccdr cdvfvtg
12748168345648065486974654600
dsdshvbds`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}