$re = '/[\]<>%!~"§$#%*&/|\\\\+()=?{}[$]|[0-9]/m';
$str = '!
"
§
$
%
&
/
(
)
=
?
{
}
[
]
\\
#
*
+
~
<
>
|
dccdr cdvfvtg
12748168345648065486974654600
dsdshvbds';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);