re = /[\]<>%!~"§$#%*&\/|\\+()=?{}[$]|[0-9]/m
str = '!
"
§
$
%
&
/
(
)
=
?
{
}
[
]
\\
#
*
+
~
<
>
|
dccdr cdvfvtg
12748168345648065486974654600
dsdshvbds'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end