// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)[\]<>%!~"§$#%*&/|\\+()=?{}[$]|[0-9]"#).unwrap();
let string = "!
\"
§
$
%
&
/
(
)
=
?
{
}
[
]
\\
#
*
+
~
<
>
|
dccdr cdvfvtg
12748168345648065486974654600
dsdshvbds";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}