$re = '/youtube\.com\/watch\?v\=([0-9a-zA-Z]+)/m';
$str = 'https://www.youtube.com/watch?v=blabla42';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);