const regex = /^5[1-5]\d{14}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^5[1-5]\\d{14}$', 'gm')
const str = `5245123412347894
5645123412347894
5241123412347894
6245123412347894
12451234123478AA`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}