using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Endine nimi\s*<\/td>\s*<td[^>]*>\s*(.*?)\s*<\/td>";
string input = @"Endine nimi </td>
<td >
MORENOL OÜ </td>";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}