$re = '/^(\d+\.)(\d+\.)(\*|\d+)$/m';
$str = '1
1.2
1.2.3
111
222.222
111.222.333';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);