import Foundation
let pattern = #"\s+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"1
2
3"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)