re = /\s*\d+[.,]\d+/m
str = 'Mazda 6 2.0 Skyactiv-G Wagon 2018 - Startstop.sk - TEST
Mercedes C63 AMG Sound REVVING 6,3l V8 '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result