#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\*\s+<< BeReq\s+>> (?P<request>\d+) ?$" & @CRLF & _
"^-\s+BackendOpen\s+\d+ (?P<backend>[^ ]+) .+$" & @CRLF & _
"^-\s+BerespStatus\s+(?P<status>\d{3})$" & @CRLF & _
"^-\s+Timestamp\s+BerespBody: (?P<timestamp>[\d.]+) (?P<response_time>[\d.]+) .+$"
Local $sString = "* << BeReq >> 416335894 " & @CRLF & _
"- BackendOpen 137 boot.https_app3 10.1.10.8 8443 10.1.10.10 45467" & @CRLF & _
"- BerespStatus 200" & @CRLF & _
"- Timestamp BerespBody: 1536053067.307297 0.002362 0.000701" & @CRLF & _
"" & @CRLF & _
"* << BeReq >> 417244880 " & @CRLF & _
"- BackendOpen 62 boot.https_app4 10.1.10.9 8443 10.1.10.10 50995" & @CRLF & _
"- BerespStatus 200" & @CRLF & _
"- Timestamp BerespBody: 1536053067.427519 0.120675 0.001029" & @CRLF & _
"" & @CRLF & _
"* << BeReq >> 411778166" & @CRLF & _
"- BackendOpen 77 boot.https_app3 10.1.10.8 8443 10.1.10.10 39506" & @CRLF & _
"- BerespStatus 304" & @CRLF & _
"- BerespStatus 200" & @CRLF & _
"- Timestamp BerespBody: 1536052222.383470 0.009091 0.000151"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")