// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)['"](Text [\d]+)["']"#).unwrap();
let string = "case 'cryptocurrencies':
return this.$t('Text 1', { company: this.$global.company, num: this.$global.companyAge });
case 'currencies':
return this.$t(
'Text 2',
{
company: this.$global.company,
num: this.$global.companyAge
}
);
${ this.$t(\"Text 3\", { company: this.$global.company }) } ${ this.$t(\"Text 4\", { num: this.bonus }) }
${ this.$t('Text 3', { company: this.$global.company }) } ${ this.$t('Text 4', { num: this.bonus }) }";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}