using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((G[ou]{2,}d{1,})|Great|Awesome) ((Morning|Afternoon|Evening|Night)\/?){2,} (ya|ever|all)";
string input = @"Oh! Good morning waffle!
Nevah!
Not for another 12 ish Horus at least
perfect
Ye
Ooof sorry
O
O
ÙwÚ
*I will always test loopholes uwu*
Could try
UwU
could be better could be worse
ok so its random good
Good Evening/Afternoon/Morning/Night yall
Good Night/Evening/Afternoon/Morning ya
Ty
Hours*
hope u two goodnight
ooo";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}