# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((G[ou]{2,}d{1,})|Great|Awesome) ((Morning|Afternoon|Evening|Night)\/?){2,} (ya|ever|all)"
test_str = ("Oh! Good morning waffle!\n"
"Nevah!\n"
"Not for another 12 ish Horus at least\n"
"perfect\n"
"Ye\n"
"Ooof sorry\n"
"O\n"
"O\n"
"ÙwÚ\n"
"*I will always test loopholes uwu*\n"
"Could try\n"
"UwU\n"
"could be better could be worse\n"
"ok so its random good\n"
"Good Evening/Afternoon/Morning/Night yall\n"
"Good Night/Evening/Afternoon/Morning ya\n"
"Ty\n"
"Hours*\n"
"hope u two goodnight\n"
"ooo")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.