use strict;
my $str = 'dev/earth/resized/100x100/s/70/earth.jpg
dev/earth/resized/100x100/70/earth.jpg
dev/earth/resized/100x100/s/earth.jpg
dev/earth/resized/100x100/earth.jpg';
my $regex = qr/(?P<path>([a-zA-Z0-9_-]+\/)+)(?P<dimensions>[0-9]{1,4}x[0-9]{1,4})\/((?P<mode>[cs])\/)?((?P<quality>[0-9]{1,3})\/)?(?P<name>[a-zA-Z_\.-0-9]+\.[a-z]{3})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}