Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^(?:(?!ab|cd)(.))+$
/
gm
Test String
New
This text won\'t match because it does contain ab in it! This text won\'t match because it does contain cd in it! This text matches because it doesn\'t contain them in itghdfgdfg!