use strict;
my $str = 'idss-static-frame.spec';
my $regex = qr/(\w+)(?:-|\.\w+$)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";