re = /^(?!word$).+/m
str = 'word
anywordnow
anything
else
word-workers
workers-word
wrodweb
workers
exports
project-explorer'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end