import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)data-rlocation=\"([^\\r\\n\"]*)\"";
final String string = "<p class=\"sm clg\" data-rlocation=\"Uttam Nagar East\">Uttam Nagar East, Delhi <span class=\"to-txt\" id=\"citytt1\">B-24, East Uttam Nagar, Uttam Nagar East,<br>Delhi<span> - </span>110059\n"
+ "<p class=\"sm clg\" DATA-rlocation=\"Uttam Nagar East\">Uttam Nagar East, Delhi <span class=\"to-txt\" id=\"citytt1\">B-24, East Uttam Nagar, Uttam Nagar East,<br>Delhi<span> - </span>110059\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}