$re = '/s(?<![is]s)\b/';
$str = '("class","guests","trips","sassy","basis","fruits")';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);