use strict;
my $str = 'SWL-101
just did it
SWL-101: wip something is about to be done
SWL-102: wip
SWTS-103, we did something cool
SWM-104, i am groot!
';
my $regex = qr/^SW(TS|L|M)-(\d+)([:,] )([wW][iI][pP])?(?(4)[ \w]{3,}|(?!([wW][iI][pP]))[ \w]{3,}).*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}