$re = '/(.*)(\bfirstname=rahman\b)(.*)(\blastname=mahmoodi\b)(.*)(\bcountry=canada\b)(.*)/';
$str = 'firstname=rahman, middlename=abdul, lastname=mahmoodi, country=australia
firstname=rahman, middlename=james, lastname=mahmoodi, country=canada
firstname=rahman, middlename=james, lastname=mahmoodi, country=new zealand';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);