# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d{4}-\d{1,2}-\d{1,2})_(\d{2}-\d{2}-\d{2}).*\.(\d+)"
test_str = ("Toolx-2022-01-18_15-26-09.blf.26\n"
"Temperaturelow-2022-01-18_15-26-09.blf.27\n"
"Temperaturehigh2022-01-18_15-26-09.blf.28\n"
"low2022-01-18_15-26-09.blf.29\n"
"high2022-01-18_15-26-09.blf.30")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.