// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^/(?:[^/\\0,\n]+/?)*$").unwrap();
let string = "/
/foo
/foo/bar/with/special/chars/a&b
/foo/with whitespace
name
name/subdir
/exception, due to \",\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}