# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<[^>]*>([^<]*)<[^>]*>/<outline text="$1"><\/outline>/gm;t' <<< "<col id=\"7\" type=\"TEXT\"> Speaker</col>
<col id=\"7\" type=\"TEXT\"> Monitor</col>
<col id=\"7\" type=\"TEXT\"> TV</col>
<col id=\"7\" type=\"TEXT\"> Amp</col>"