using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<[^>]*>([^<]*)<[^>]*>";
string substitution = @"<outline text=""$1""></outline>";
string input = @"<col id=""7"" type=""TEXT""> Speaker</col>
<col id=""7"" type=""TEXT""> Monitor</col>
<col id=""7"" type=""TEXT""> TV</col>
<col id=""7"" type=""TEXT""> Amp</col>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}