#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\n|\s$)"
Local $sString = "★★★★★★: Nearl the Radiant Knight (Limited)" & @CRLF & _
"★★★★★★: Flametail / Rosmotis" & @CRLF & _
"★★★★★: Corroserum [limited] / Liskarm The Charging Wyvern (Limited)" & @CRLF & _
"★★★★★: Wild Mane" & @CRLF & _
"★★★★★: Honeyberry" & @CRLF & _
"★★★★: Pudding [limited]" & @CRLF & _
"★★★★★★: Nearl the Radiant Knight [Limited] / Flametail (70% in 6* Operators)" & @CRLF & _
"★★★★★: Corroserum (50% in 5* Operators)" & @CRLF & _
"★★★★★★: W [Limited] / Rosmontis [Limited] (Rate up in the rest 30% in 6* Operators)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")