use strict;
my $str = '★★★★★★: Nearl the Radiant Knight (Limited)
★★★★★★: Flametail / Rosmotis
★★★★★: Corroserum [limited] / Liskarm The Charging Wyvern (Limited)
★★★★★: Wild Mane
★★★★★: Honeyberry
★★★★: Pudding [limited]
★★★★★★: Nearl the Radiant Knight [Limited] / Flametail (70% in 6* Operators)
★★★★★: Corroserum (50% in 5* Operators)
★★★★★★: W [Limited] / Rosmontis [Limited] (Rate up in the rest 30% in 6* Operators)';
my $regex = qr/(?:\n|\s$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}