using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(((http|https):)?//?)(lkker-10041312\.file\.myqcloud\.com|lkker-10041312\.cossh\.myqcloud\.com|pic\.lkker\.com|files\.lkker\.com|lkker-10041312\.picsh\.myqcloud\.com|lkker-10041312\.image\.myqcloud\.com|images\.lkker\.com)";
string input = @"http://lkker-10041312.file.myqcloud.com/Images/201712/SrOq15133074890982.png
http://pic.lkker.com/afdsafds
//images.lkker.com/afdsafds
{""A"":""//images.lkker.com/afdsafds"", ""B"":""//images.lkker.com/afdsafds""}
//images.lkker.com/afdsafds|https://images.lkker.com/afdsafds|http://images.lkker.com/afdsafds";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}