import Foundation
let pattern = #"(?:194 Temperature[^(\n]+|Airflow_Temperature[^(\n]+|Drive Temperature:|Temperature:) +([0-9]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
WD: 194 Temperature_Celsius 0x0022 105 100 000 Old_age Always - 42
Seagate: 194 Temperature_Celsius 0x0022 034 053 000 Old_age Always - 34 (0 16 0 0 0)
Toshiba: 194 Temperature_Celsius 0x0002 122 122 000 Old_age Always - 49 (Min/Max 15/57)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)