using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"news\/[a-z0-9_-]+$";
string input = @"news/news_url
news/page/3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}