package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^Zn](\.\s)`)
var str = `aaa. Zn. bbb
aaa. Zn. bbb.
aaa Zn. bbb.
aaa Zn. bbb
aaa Bns. bbb
aaa Bns. Bbb
aaa Zn. Aaa Bns. Bbb
1
aaa
aaa.
aaa Abbb
aaa. Zns. bbb
aaa. Zns. bbb.
aaa Zns. bbb.
aaa Zns. bbb`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}