#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\^(?=[A-Z .()\/-]{1,24}\^)[A-Z .()-]*\/[A-Z .()-]*\^"
Local $sString = "^TEST/TEST^" & @CRLF & _
"^TEST TEST^" & @CRLF & _
"^TEST/TE/ST^" & @CRLF & _
"^TEST/TE+ST^" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"^^" & @CRLF & _
"^/^" & @CRLF & _
"^/A^" & @CRLF & _
"^A/^" & @CRLF & _
"^//^" & @CRLF & _
"^A/A^"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")