use strict;
my $str = 'drwxr-xr-x 1 saulo 197609 0 1643302767 img
-rwxr-xr-x 1 saulo 197609 814 1646247422 folder_files.sh
-rw-r--r-- 1 saulo 197609 2962 1646247491 README.md
-rwxr-xr-x 1 saulo 197609 59 1654780176 gitp
drwxr-xr-x 1 saulo 197609 0 1654780219 pessoal
-rwxr-xr-x 1 saulo 197609 1022 1654780442 folder_files.py
-rw-r--r-- 1 saulo 197609 226 1654781546 folder_files.php';
my $regex = qr/^.*\s+(\d+)\s(\d+)\s(.*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}